See our current list of officially supported devices here. If your device is not on this list, it may still work if it meets all of the following three requirements:

 

1. Our devices require BLE (Bluetooth Low Energy a.k.a Bluetooth 4.0) to connect to the app. BLE is only available in certain operating systems and phones. (Android users: the following app will allow you to confirm if your phone/tablet possesses BLE - https://play.google.com/store/apps/details?id=com.magicalboy.btd&hl=en)


2. iOS requires version 8 and higher (iPhone 4 excluded due to BLE requirement), Android requires version 4.4 and higher. 

 

3. Your phone must have at least a 4-inch display, measured from the bottom left corner of the screen to the top right corner.

 

Please note, the Walgreens Premium Activity Tracker does not sync with a computer. You must have a compatible smartphone or tablet to use it.